Symptoms
One or more of the following:
• The WPL Printer Driver Wizard says it completed, but the "completed successfully" list is empty and no printer is actually installed.
Note: Make sure you're using an up-to-date version of the driver. Versions 2019, 2018, 7.3.3, and 7.3.0 are compatible with 10, 8, 7, Vista, XP. Version 7.1.x is only compatible with Windows XP.
• The Print Management utility refuses to remove a print driver package, saying it's in use. No printer is using the driver. Multiple reboots have been performed. Note: Print Management is not included with Home/Standard editions of Windows, so skip past this section.
• Print Management's Drivers Inf Path column is blank for a driver. The Driver Version column may be blank.
Cause
Corruption in the Windows registry.
Resolution
Delete the print driver from the Registry:
- Launch Registry Editor (regedit). Navigate to and expand out the following registry path:
64-bit Windows: Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Drivers\Version-3
32-bit Windows: Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-3 - In the left pane, right-click the print driver, Delete, Yes.
- Collapse the Environments key and expand Printers just below it. Full path:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers - If your printer is there, right-click it, Delete, Yes. If your printer is not there, go to the next step.
- Click Start, type "services.msc" into the search field, then Enter.
- Double-click Print Spooler. Click Stop, wait, then Start to restart the service.
More information:
1. Print Management is available on Pro or higher editions of Windows (but not Standard). It can be found in Control Panel, Administrative Tools, or run printmanagement.msc