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  • Multiple Products: service stops repeatedly on Windows Server with DNS service
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Multiple Products: service stops repeatedly on Windows Server with DNS service

Scott Leonard
2017-04-10
in Version 7
This article applies to InventoryControl, MobileAsset, and WaspTime (with services Wasp Inventory Windows Service, Wasp MobileAsset Windows Service, WaspTime Server Service, and WaspLicMgr on older products).
 

Symptom

On Windows Server operating systems with the DNS service enabled, the Wasp product's service will not stay started. This prevents mobile devices from communicating with the database. Professional Edition PC clients will not run because the license manager component is not running.
 
The service's log file contains errors similar to the following:
 
2016-09-30 11:55:27.628         12 --------------- ERROR       | Error trying to listen on port 10004
 
2016-09-30 11:55:27.630         12 --------------- ERROR       | Terminating Application - Port may already be in use!
 

Cause

The DNS service uses many ports, and the Wasp service will terminate if a port conflict occurs.
 

Resolution

The Standard and Professional editions of InventoryControl and MobileAsset must be installed on a PC/server without the DNS service.
 
The Enterprise editions of IC & MA, and any edition of WaspTime, can install their services to a different PC/server with the DNS service. (For these editions, moving the database is optional.) Rerun the program's installer and check the box for the service when prompted with component options. Client PCs can rerun the installer, or simply edit the License Server value in the registry.

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