Navigate
Wasp Helpdesk
  • Register

  • or
  • Login
    Need a password reminder?
or
Contact Us
  • Get in touch

    Send us an email

  • Start a chat session

  • Knowledgebase Read help articles
  • News News & updates
  • Contact Us We are here to help
  • Training View our options
  • Product Sunsets Non-Supported Products
Barcode System Consult
Barcode Printer Consult
Barcode Label Consult
  • Portal
  • Knowledgebase
  • Hardware
  • Mobile Computers
  • MobileAsset v7: Windows Mobile/CE device gives NullReferenceException error when database is on a memory card
Subscribe Download PDF

MobileAsset v7: Windows Mobile/CE device gives NullReferenceException error when database is on a memory card

Scott Leonard
2025-01-06
in Mobile Computers

Symptoms

  • MobileAsset v7 is being used on a Windows Mobile/CE device.
  • At initial download of the database to the device, user chose to store the database on a memory card.
  • When editing, auditing, or other operation where an asset tag is entered, one or more error messages appear:
    NullReferenceException
    Database error while trying to locate an existing asset.: NullReferenceException

    mav7-nullreferenceexception-1.png mav7-nullreferenceexception-2.png

Cause

The MobileAsset.sdf database file is saved in the root of the memory card, but the program expects the database file to be in at least one folder. 

Workaround

  1. Before the initial database download, create a folder on the memory card (suggested name: Database), using Windows Explorer on the mobile device, or Windows File Explorer on the PC. At initial download time, specify this folder.

  2. Or, if the database is already on the memory card, move the file and update the path in the configuration file:
  1. Quit MobileAsset on the device.

  2. Connect the mobile device to the PC so that it shows connected in Windows Mobile Device Center.

  3. In WMDC or Windows File Explorer, browse the contents of the device.

  4. Go into the memory card (which could be called Flash Disk, SDMMC, or some other name). Create a folder there (suggested name: Database), then move the MobileAsset.sdf file into the folder.

  5. Edit the configuration file: Copy the device's file \Program Files\MobileAsset\service.config to the PC, then open the PC's copy of the file in Notepad or other text editor. Add the folder name you created in Step 2d into the <SdfPath> section, then save the file. For example:

    original: mav7-service-config-sdfpath-orig.png

    fixed: mav7-service-config-sdfpath-fixed.png

  6. Copy the file back to the device, replacing the original.

  7. Now the device can be used as expected, and the error should no longer appear.

Rate the quality of this page

This page was helpful :) :( This page was not helpful

1 of 4 people found this page helpful


Quick Jump
  • Wasp Helpdesk
  • Knowledgebase
  • News
  • Contact Us
Top
Helpdesk software provided by Deskpro