Symptom
Although MobileAsset v7 should not require a separate mobile device license for Wasp-branded devices, when you use the Wasp-branded WDT92, DR2, or DR3 mobile devices with MobileAsset v7:
- The device returns a message "No available licenses".
or - The device uses up one of your already-entered non-Wasp mobile device licenses.
Cause
The WDT92, DR2, and DR3 devices were released after MobileAsset v7, so MobileAsset is not aware of those device types.
Resolution
The following batch file updates MobileAsset to recognize the WDT92, DR2, and DR3.
Download, save, and extract the following zip file on the server (the PC that holds the database):
Inside the extracted folder, double-click the UpdateDB.bat file. The change takes effect immediately. Note: The zip file must be extracted first. If UpdateDB.bat is run from within the zip file, it will not work.
Note: For Enterprise edition customers whose SQL instance is not WASPDBEXPRESS, first edit the script.wql file with a text editor so that the server= line contains the proper server and instance (if any).