Symptoms
- When launching a MobileAsset v7 PC client, nothing happens. The login screen never appears.
- In Task Manager, mobileasset.exe appears for a few seconds, then disappears.
- In the MobileAsset.log error file, the following error is seen: "Failed to copy the license key to the data store. Exception info: A connection was successfully established with the server, but then an error occurred during the login process. (provider: SSL Provider, error: 0 - The message received was unexpected or badly formatted.)"
- Other PC clients may be able to log in and connect successfully with MobileAsset.
Cause
The client PC has Microsoft .NET Framework 4.5.1 installed.
Resolution
- In the Windows control panel Programs and Features, uninstall Microsoft .NET Framework 4.5.1.
- Download and install one of the following later versions:
Microsoft .NET Framework 4.5.2:
http://www.microsoft.com/en-us/download/details.aspx?id=42642
Microsoft .NET Framework 4.6.1:
https://www.microsoft.com/en-us/download/details.aspx?id=49982