Symptom
When using MobileAsset v7 on an iOS device, you attempt to use the device's camera to scan a barcode, but the device only shows a black screen.
Cause
At the initial use of MobileAsset, iOS's security features prompted whether to allow access to the camera, and the user chose to not allow the use of the camera. In subsequent uses of the app (even after deleting and redownloading), it never prompts again for permission to use the camera.
Resolution
Launch iOS's Settings app, swipe up to find MobileAsset in the apps list, tap the > button, and swipe the Camera slider to the right to enable MobileAsset to use the camera.