Navigate
Wasp Helpdesk
  • Register

  • or
  • Login
    Need a password reminder?
or
Contact Us
  • Get in touch

    Send us an email

  • Start a chat session

  • Knowledgebase Read help articles
  • News News & updates
  • Contact Us We are here to help
  • Training View our options
  • Product Sunsets Non-Supported Products
Barcode System Consult
Barcode Printer Consult
Barcode Label Consult
  • Portal
  • Knowledgebase
  • Discontinued Products
  • MobileAsset
  • Version 7
  • MobileAsset v7: Error Code 1002 occurs when opening a list
Subscribe Download PDF

MobileAsset v7: Error Code 1002 occurs when opening a list

Scott Leonard
2023-01-23
in Version 7

Symptom

When opening a list, MobileAsset immediately gives an error:
 
Error in Application
Error executing sql statement. Database timeout period elapsed prior to completion of a SQL query or the server is not responding.
Error Code: 1002
 
ma7-error-1002.png

Cause

The list's default view's filter has invalid data or Find criteria. This could happen after upgrading from an earlier version, but the upgrade process didn't convert the view properly due to changes in the database format.

Resolution

You may need to use more than one suggestion to fix the problem completely.
  1. In the toolbar, click Toggle so the filter is not shown.
  2. Delete the view.
  3. Set a different view as default.
  4. Recreate the filter settings so the list displays properly.
  5. Save the properly-displayed view with the same name to overwrite the bad view.

Rate the quality of this page

This page was helpful :) :( This page was not helpful

11 of 31 people found this page helpful


Quick Jump
  • Wasp Helpdesk
  • Knowledgebase
  • News
  • Contact Us
Top
Helpdesk software provided by Deskpro