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  • MobileAsset v7: At launch, error: Login failed for user 'AssetUser', then login prompt, then longer 'Login failed' error
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MobileAsset v7: At launch, error: Login failed for user 'AssetUser', then login prompt, then longer 'Login failed' error

Scott Leonard
2025-01-06
in Version 7

Symptoms

  • When launching a MobileAsset v7 PC client (from any PC, including the database PC/server), there is an error: Login failed for user 'AssetUser'.

    ma7-assetuser-login-small-sql-auth.png

    Then the usual MobileAsset login prompt appears.

    ma7-login.jpg

    After attempting to log in with any MobileAsset credentials, a longer login error appears:
    Login failed for user 'AssetUser'. This most possibly means that AssetUser account is not setup properly in the Wasp Configuration database. The account is either not there at all or it doesn't have access to the wasp configuration database. (error continues)

    ma7-assetuser-login-large-sql-auth.png

  • On the PC client, the MobileAsset.log file includes the following errors (other verbiage appears between these lines):
    2015-11-30 10:56:35.174          1 ERROR       | Failed to copy the license key to the data store. Exception info: Login failed for user 'AssetUser'.
    2015-11-30 10:56:35.846          1 ERROR       | Login failed for user 'AssetUser'.
    2015-11-30 10:56:37.681          1 ERROR       | Error checking for sample company: Login failed for user 'AssetUser'.
    2015-11-30 10:56:41.145          1 ERROR       | Exception in ShowMultiCompayLogonDialog: System.Data.SqlClient.SqlException (0x80131904): Login failed for user 'AssetUser'.

  • On the Asset Service PC, the WaspMobileAssetServices.log file contains the following error:
    2015-11-30 10:58:39.451          9 --------------- ERROR       | GetMobileAssetDatabases() exception occur: Login failed for user 'AssetUser'.

     
  • SQL Server is installed and running.
  • The AssetUser account has proper access to the WaspConfig database.
  • The account is not locked out.
  • The account is set to the proper password.

Cause

The SQL instance is set to only allow Windows Authentication. MobileAsset uses the SQL account AssetUser to perform its transactions, but is unable to log in.

sql2008-srvprop-security.png
 

Resolution

In SQL Server Management Studio, set the Server Authentication to SQL Server and Windows Authentication mode:
  1. Start, All Programs, Microsoft SQL Server 2008 R2, SQL Server Management Studio.

  2. Make sure Authentication is set to Windows Authentication, then Connect.

  3. At the top of the list at the upper left, find the SERVER\INSTANCE name (or possibly just SERVER).

  4. Right-click it, Properties.

  5. In the upper left list, click Security.

  6. Click SQL Server and Windows Authentication mode (as in the screenshot above), then OK.

  7. Click OK on the notification about restarting the SQL Server.

  8. Start, type services.msc then launch it when found.

  9. In the list, find SQL Server (INSTANCE).

  10. Right-click it, Restart.

  11. Now when launched, MobileAsset should give the login prompt without error.

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