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  • InventoryControl v7: The service is started, but mobile devices can't connect
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InventoryControl v7: The service is started, but mobile devices can't connect

Jason Whitmer
2025-01-07
in Version 7

Symptoms:

Mobile devices report that they are unable to make a connection with the service, but when you ping the server's IP address from the Summit Client Utility, they are getting correct responses.

Checking the Services list on the server, Wasp Inventory Windows Service says it is Started.

From a pc's browser, if you attempt to connect with http://<server>:10005 (replacing <server> with the server's machine name, fully qualified domain name, or IP address), it responds "This webpage is not available" or similar message, depending on your browser.

On the server machine, C:\ProgramData\Wasp Barcode Technologies\WaspInventoryWindowsService\6.0.0.0\WaspInventoryServices.log shows this error:

Wasp Inventory Windows Service starts failed.
Service 'Wasp.Inventory.Service.InventoryService' has zero application (non-infrastructure) endpoints. This might be because no configuration file was found for your application, or because no service element matching the service name could be found in the configuration file, or because no endpoints were defined in the service element.

Cause:

One ore more config files needed for the service to run properly are missing from C:\Program Files (x86)\Wasp Technologies\InventoryControl\Services on the PC running Wasp Inventory Windows Server (often the same as the database server).

Resolution:
Download https://dl.waspbarcode.com/wasp/supportfiles/IC7ServiceConfig.zip and extract it to C:\Program Files (x86)\Wasp Technologies\InventoryControl\Services on the server (or C:\Program Files\Wasp Technologies\InventoryControl\Services if it is a 32 bit version of Windows) and then edit the two files to make the following changes:

1. In Change Configuration Settings.exe.config, search for SERVER.FQDN and replace it with the server's fully qualified domain name. E.g., INVENTORY.WASP.COM. This will be on only 1 line in the file.

2. In WaspInventoryWindowsService.exe.config, search for SERVERNAME and replace it with the server's machine name. E.g., INVENTORY. This will be on only 1 line in the file.

3. Also in WaspInventoryWindowsService.exe.config, search for SERVER.FQDN and replace it with the server's fully qualified domain name. E.g., INVENTORY.WASP.COM. This will be on 2 lines in this file.

3. On the Services list, stop the Wasp Inventory Windows Service, wait 10 seconds, then Start it. Once it is restarted, the mobile device should be able to connect.

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