Symptoms
- When launching an InventoryControl v7 PC client (from any PC, including the database PC/server), there is an error:
Database was not found. The database needed for this application is either not running or not exist in server SERVER\INSTANCE.
Login failed for user 'InventoryUser'. - On the PC client, the InventoryControl.log file includes the following error:
2015-11-30 12:24:06.179 1 ERROR | Failed to initialize the Database. - On the Inventory Service PC, the WaspInventoryServices.log file includes the following error:2015-11-30 14:44:30.597 11 --------------- ERROR | GetOptionBooleanValue() Error. Option Code: 110. Login failed for user 'InventoryUser'.
-
SQL Server is installed and running.
- The InventoryUser account has proper access to the WaspTrackInventory database.
- The account is not locked out.
- The account is set to the proper password.
Cause
The SQL instance is set to only allow Windows Authentication. InventoryControl uses the SQL account InventoryUser to perform its transactions, but is unable to log in.
Resolution
In SQL Server Management Studio, set the Server Authentication to SQL Server and Windows Authentication mode:
- Start, All Programs, Microsoft SQL Server 2008 R2, SQL Server Management Studio.
- Make sure Authentication is set to Windows Authentication, then Connect.
- At the top of the list at the upper left, find the SERVER\INSTANCE name (or possibly just SERVER).
- Right-click it, Properties.
- In the upper left list, click Security.
- Click SQL Server and Windows Authentication mode (as in the screenshot above), then OK.
- Click OK on the notification about restarting the SQL Server.
- Start, type services.msc then launch it when found.
- In the list, find SQL Server (INSTANCE).
- Right-click it, Restart.
- Now when launched, InventoryControl should give the login prompt without error.