Symptoms
- When launching a WaspTime v7 PC client (from any PC, including the database PC/server), there is an error: The WaspTime client failed to connect to the database. The client must close.SQL error message:Login failed for user 'TimeUser'.
- On the PC client, the WaspTime5.log file includes the following error:
2015-11-30 14:21:41.766 1 FORCE | Unable to access database (sql message): Login failed for user 'TimeUser'. - On the Time Service PC, the WaspTimeServer.log file includes the following error:2015-11-30 12:02:53.590 11 Service...Scheduler ERROR | Login failed for user 'TimeUser'.
-
SQL Server is installed and running.
- The TimeUser account has proper access to the WaspTime database.
- The account is not locked out.
- The account is set to the proper password.
Cause
The SQL instance is set to only allow Windows Authentication. WaspTime uses the SQL account TimeUser to perform its transactions, but is unable to log in.
Resolution
In SQL Server Management Studio, set the Server Authentication to SQL Server and Windows Authentication mode:
- Start, All Programs, Microsoft SQL Server 2005, SQL Server Management Studio.
- Make sure Authentication is set to Windows Authentication, then Connect.
- At the top of the list at the upper left, find the SERVER\INSTANCE name (or possibly just SERVER).
- Right-click it, Properties.
- In the upper left list, click Security.
- Click SQL Server and Windows Authentication mode (as in the screenshot above), then OK.
- Click OK on the notification about restarting the SQL Server.
- Start, type services.msc then launch it when found.
- In the list, find SQL Server (INSTANCE).
- Right-click it, Restart.
- Now when launched, WaspTime should give the login prompt without error.