Navigate
Wasp Helpdesk
  • Register

  • or
  • Login
    Need a password reminder?
or
Contact Us
  • Get in touch

    Send us an email

  • Start a chat session

  • Knowledgebase Read help articles
  • News News & updates
  • Contact Us We are here to help
  • Training View our options
  • Product Sunsets Non-Supported Products
Barcode System Consult
Barcode Printer Consult
Barcode Label Consult
  • Portal
  • Knowledgebase
  • Software
  • WaspTime: Error attempting to unarchive an employee: The unarchive failed (with error in log file: Value was either too large or too small for an Int32)
Subscribe Download PDF

WaspTime: Error attempting to unarchive an employee: The unarchive failed (with error in log file: Value was either too large or too small for an Int32)

Scott Leonard
2017-04-10
in Software

Symptoms

When attempting to unarchive an employee, an error occurs: "The unarchive failed. This is most likely because there are not enough employee or manager licenses left. Check the log file for more detail."
 
However, there is an available employee or manager license (verified in Help menu, About).
 
The wasptime5.log file shows this error: "Exception UnArchiving employee: Value was either too large or too small for an Int32."

Cause

The Employee ID of the employee you're trying to unarchive is the same as another Employee ID. This happens when the user sets the Employee ID of a new employee to the same Employee ID of an Archived user. (Note: WaspTime will refuse to allow reuse of an Employee ID of an Active or Inactive user.) 

Resolution

Edit the Employee ID so that it is unique in the system. The error will no longer occur.

Rate the quality of this page

This page was helpful :) :( This page was not helpful

5 of 9 people found this page helpful


Quick Jump
  • Wasp Helpdesk
  • Knowledgebase
  • News
  • Contact Us
Top
Helpdesk software provided by Deskpro