Skip to main content

MobileAsset v7.1: client quits immediately, log: Unable to load DLL 'WaspAct.dll' - Knowledgebase / Software - Wasp Helpdesk

MobileAsset v7.1: client quits immediately, log: Unable to load DLL 'WaspAct.dll'

Authors list

Symptoms 

  • Starting with a working installation of MobileAsset v6.x, the MobileAsset v7.1 patch was run attempting to upgrade the version. However, when the MA client is launched, it quits immediately with no error. The MobileAsset.log file contains an error:
    FATAL | Unable to load DLL 'WaspAct.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)

  • MobileAsset's installation directory does contain WaspAct.dll, with the correct recent date. 

Cause

Incremental patch installers do not contain all the files needed to upgrade major version numbers (e.g. from v6.x to v7.x), and will cause problems. To upgrade the major version number, the full installer for the new version must be run. This is obtained by purchasing an upgrade license which includes a disc or downloaded installer. 

Resolution

Run the full version installer and do the Reinstall option, on all MobileAsset PCs. 

Note 

Customers with the Enterprise edition using additional databases should contact Wasp Support for assistance upgrading those additional databases.
Helpful Unhelpful

7 of 10 people found this page helpful