Symptoms
You have entered information for Customers, Employees, Manufacturers, or Suppliers, but the list is blank.
When you try to re-create one of those items, the program says it already exists.
Cause
Some customers are seeing an issue where some or all of the data from the Address table in the database has disappeared, which will cause those lists in the program to not populate properly.
Resolution
- Download https://dl.waspbarcode.com/wasp/supportfiles/MA6AddAllAddresses.zip and extract it on the server machine.
- If you are running the Enterprise version, edit AddAllAddress.wql and put in the correct server/instance name.
- Run AddAllAddress.bat.
Running this file will create new empty records in the address table, allowing the lists to open correctly. Since the address information is gone from the database, there is no way to recover it. You will need to edit the entries on the lists to type it back in as needed.
This will also create a default record for the company address, if you are having trouble opening the Company Information window.