Skip to main content

Multiple Products: When attempting to open reports, they prompt for a login, often with WaspReader entered as the login ID - Knowledgebase / Discontinued Products / MobileAsset - Wasp Helpdesk

Multiple Products: When attempting to open reports, they prompt for a login, often with WaspReader entered as the login ID

Authors list

Applies to InventoryControl, MobileAsset, WaspTime

Symptom

When you attempt to run a report, you receive a prompt:

Database Login

Server Name: <server>

Database: <blank>

Login ID: WaspReader

Password: ********

Clicking the Finish button gives a Login Failed message.

Note: The Login ID might be different, such as TimeUser or AssetReader.

Possible Cause 1

The SQL Native Client is not installed or corrupted.

Solution 1

In Programs and Features, if "Microsoft SQL Server Native Client" is listed, right-click and uninstall it.

Rerun the SQL Native Client installer from the installation disc. Alternately, the installer can be downloaded here:

64-bit Windows: https://dl.waspbarcode.com/wasp/supportfiles/sqlncli_x64.zip

32-bit Windows: https://dl.waspbarcode.com/wasp/supportfiles/sqlncli.zip


Possible Cause 2

TLS 1.0 has been disabled on the database PC and/or the workstation running the report.


Solution 2

On any affected PC, follow the resolution in the article "Multiple Products: SQL Server service will not start, error code -2146893007" which is linked below in Related Pages.

Helpful Unhelpful

6 of 31 people found this page helpful