This problem has been observed in AssetCloud and InventoryCloud On-Premise v02.02.03 @ 12/05/2023 (Build:2.2.2.30957). The next (and later) On-Premise build will include this fix, so the workaround below should no longer need to be applied manually.
Symptoms
After upgrade or installation of the version mentioned above, the AssetCloud or InventoryCloud On-Premise website will occasionally stop working. Users who are already logged in receive no results; other users attempting to log in get a message "Page unavailable. The requested page failed to load..."
Logged errors include "System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host."
Cause
A Microsoft Windows update in late 2023 introduced changes in the operating system that causes the website to disconnect.
Workaround
A registry change sets the error to only generate a warning in Event Viewer, rather than causing a disconnect.
You will see warnings in Event Viewer. Source Directory-Services-SAM, event ID 16968. General notes: Audit only mode is currently enabled for remote calls to the SAM database. The following client would have been normally denied access: Client SID: [value] from network address [ipaddress]. For more information, please see http://go.microsoft.com/fwlink/?LinkId=787651.
Registry | Details |
Path | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa |
Setting | RestrictRemoteSamAuditOnlyMode |
Data Type | REG_DWORD |
Value | 1 |
Notes | This setting can't be added or removed by using predefined Group Policy settings. Administrators may create a custom policy to set the registry value if needed. SAM responds dynamically to changes in this registry value without a reboot. |