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MobileAsset v7: attempting full sync on mobile device: Error uploading chunk 0... - Knowledgebase / Hardware / Mobile Computers - Wasp Helpdesk

MobileAsset v7: attempting full sync on mobile device: Error uploading chunk 0...

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Symptoms

  1. Attempting to do a full sync on a mobile device, the device displays an error similar to:
    Progress 3 of 3
    Uploading...
    Error uploading chunk 0, Sent=204800, Uploaded=0
    Could not find file 'C:\ProgramData\Wasp Barcode

  2. MobileAsset.log from the device contains an error similar to:
    2015-05-28 10:05:50.767 VERBOSE | exception in DoUpload Could not find file 'C:\ProgramData\Wasp Barcode Technologies\MobileAssetWindowsService\7.0.0.0\App_Data\Up635684043475785703.xml'.
Cause
In the path from the error message, on the PC running the Wasp MobileAsset Windows Service, the App_Data folder (from the full path above) is not present. The service cannot create the folder (even if it is set to log on as a Windows administrator).

Resolution

  1. If you are not showing hidden files and folders, enable that option.

  2. Manually create the App_Data folder. All folders in the full path should exist:
    C:\ProgramData\Wasp Barcode Technologies\MobileAssetWindowsService\7.0.0.0\App_Data

  3. The full sync should now complete.
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